IIS 7.5 redirection.config Issue

Dear All,

On one of server ( VM ) follwoing error occured and website was not working on it.

and after providing credintials it was not accepting , due to which IIS was not responding.so to trubleshoot the issue I used following steps .

  1. Tried to restart the application pool using following command


    C:\Windows\System32\inetsrv\appcmd.exe start apppool fyjc

    which has given following error

ERROR ( message:The WAS service is not available – try starting the service first. )”

  1. Come to know that WAS service is not working so tried to start Windows Process Activation Service through Services.msc but it didin’t get started
  2. so tried following command


    C:\Windows\System32\inetsrv\appcmd.exe wp

    To get the list of running Worker process which has taken me near the solution , it has given following error

     

    ” Exception Details: System.UnauthorizedAccessException: Filename:
    redirection.config
    Error: Cannot read configuration file due to insufficient permissions “

     

  3. Opened the file redirection.config from c:\windows\system32\inetsrv and after reading the contents of the file came to know that it is using settings from other server so deleted the below line from file

    <configurationRedirection enabled=”true”path=”\\10.10.10.60\Centralconfig$userName=”configuser1″ password=”[enc:IISRsaProvider:57686f6120447564652c2049495320526f636b73:enc]” />

  4. Saved the file redirection.config.
    The contents of redirection.config file should be as below 

    <configuration>

    <configSections>
        <section name=”configurationRedirection” />
    </configSections>

    <configProtectedData>
        <providers>
            <add name=”IISRsaProvider” type=”” description=”Uses RsaCryptoServiceProvider to encrypt and decrypt” keyContainerName=”iisConfigurationKey” cspProviderName=”” useMachineContainer=”true” useOAEP=”false” />
        </providers>
    </configProtectedData>

    <configurationRedirection />

</configuration>

      1   Tried to restart IIS
      2    Then browsed the site
      3    It Worked J
    

Found the cause of the error :- This error has occured because once we have tried for shared configuration in IIS 7.5 , which is recommaneded by Microsoft for WebFarn environment , but after testing we have removed the shared configuration from server mean while the image of server is replicated accross some of the web servers due to which the error occured.

Thanks

 

Prashant Deshpande

Advertisements

Leave a comment

Filed under Uncategorized

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s